Service outage

Incident Report for Notability

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 23:59 PDT

Investigating

Some of our services, such as Learn, uploading and viewing gallery notes, audio transcripts, and link sharing are currently experiencing issues. We will post an update once we have more information. Thank you for your patience.
Posted Jun 12, 2025 - 11:39 PDT
This incident affected: Learn, Collaboration, Gallery, and Audio Transcriptions.